font size

Textkit is a learning community- introduce yourself here. Use the Open Board to introduce yourself, chat about off-topic issues and get to know each other.
Post Reply
Bert
Textkit Zealot
Posts: 1890
Joined: Sat May 31, 2003 2:28 am
Location: Arthur Ontario Canada

font size

Post by Bert » Sat Apr 21, 2007 1:13 am

I just downloaded the Gentium font and now the font size on these boards is all of a sudden uncomfortably small.
Can I change that? If so; How?
Thanks.

User avatar
klewlis
Global Moderator
Posts: 1605
Joined: Tue Jul 29, 2003 1:48 pm
Location: Vancouver, Canada
Contact:

Post by klewlis » Sat Apr 21, 2007 1:18 am

I'm not sure... but the fonts are tiny and courier for me too, not sure how to fix that...

User avatar
edonnelly
Administrator
Posts: 988
Joined: Sun Jan 16, 2005 2:47 am
Location: Music City, USA
Contact:

Post by edonnelly » Sat Apr 21, 2007 12:09 pm

Bert,
Do you use Firefox? If so, and if the problem just appears on webpages, you can make the font bigger by holding down the ctrl key and rolling the mouse wheel. I use this all the time because I often encounter pages where the type is very small.
Ed
The lists:
G'Oogle and the Internet Pharrchive - 1100 or so free Latin and Greek books.
DownLOEBables - Free books from the Loeb Classical Library

Bert
Textkit Zealot
Posts: 1890
Joined: Sat May 31, 2003 2:28 am
Location: Arthur Ontario Canada

Post by Bert » Sat Apr 21, 2007 2:30 pm

Thanks. That did the trick.
I didn't have Firefox installed yet but with Firefox I can adjust the font size the way you said.
I don't know why it takes Gentium automatically.
I need it for one program but I don't think it is as clear as the font my computer used for Textkit before I had Gentium.

User avatar
perispomenon
Textkit Fan
Posts: 256
Joined: Sat May 20, 2006 5:19 pm
Location: Mijdrecht
Contact:

Post by perispomenon » Sat Apr 21, 2007 2:37 pm

Bert wrote:I don't know why it takes Gentium automatically.
I would like to know why Textkit picks up Gentium automatically, too. The tip Ed gave is a good workaround, but I would like to fix it once and for all.

I just set a preference in my browser to never go below font size 12. That helps a bit.

User avatar
Paul
Textkit Zealot
Posts: 700
Joined: Sun Jun 15, 2003 4:47 pm
Location: New York
Contact:

Post by Paul » Sat Apr 21, 2007 2:57 pm

perispomenon wrote:
Bert wrote:I don't know why it takes Gentium automatically.
I would like to know why Textkit picks up Gentium automatically, too. The tip Ed gave is a good workaround, but I would like to fix it once and for all.
When I helped Jeff with enabling Unicode, I provided for post contents this CSS font-family tag -

font-family: arial unicode ms, gentium, palatino linotype, georgia greek, cardo, galilee unicode gk, vusillus old face italic, Doulos SIL, Arial, Helvetica, serif;

Thus, if your browser is configured NOT to ignore web page fonts, i.e., it will honor the CSS values, then it will render our posts using the first font (reading from left to right) that it finds on your system.

Cordially,

Paul

User avatar
perispomenon
Textkit Fan
Posts: 256
Joined: Sat May 20, 2006 5:19 pm
Location: Mijdrecht
Contact:

Post by perispomenon » Sat Apr 21, 2007 3:15 pm

Paul wrote:Thus, if your browser is configured NOT to ignore web page fonts, i.e., it will honor the CSS values, then it will render our posts using the first font (reading from left to right) that it finds on your system.
Thanks for the info. Now I have to try and find a way to tell my browser (Safari) that. If any Mac user already knows? The Safari Help and Google didn't turn up anything (yet).

Chris Weimer
Textkit Enthusiast
Posts: 533
Joined: Mon Feb 13, 2006 9:34 am

Post by Chris Weimer » Sat Apr 21, 2007 5:53 pm

Do you not have Arial Unicode MS installed? It's a nifty little font and I recommend it.

User avatar
klewlis
Global Moderator
Posts: 1605
Joined: Tue Jul 29, 2003 1:48 pm
Location: Vancouver, Canada
Contact:

Post by klewlis » Sat Apr 21, 2007 6:39 pm

Chris Weimer wrote:Do you not have Arial Unicode MS installed? It's a nifty little font and I recommend it.
supposedly it comes with XP but it doesn't seem to be working for me (in firefox).

User avatar
Paul
Textkit Zealot
Posts: 700
Joined: Sun Jun 15, 2003 4:47 pm
Location: New York
Contact:

Post by Paul » Sat Apr 21, 2007 7:19 pm

Try this in Firefox (I am using 2.0.0.2):

a. Tools -> Options
b. in the resulting dialog, click the 'advanced' button in the middle fieldset entitled 'fonts and colors'
c. ensure that the checkbox labelled 'allow pages to choose their own fonts, instead of my selections above' is checked
d. OK-button your way out of the dialogs

This approach should allow the aforementioned CSS settings (with Arial Unicode MS first) to govern.

Let me know if this doesn't help.

Cordially,

Paul

P.S. - when you say "it doesn't seem to be working for me," what are the phenomena; what do you see?

User avatar
klewlis
Global Moderator
Posts: 1605
Joined: Tue Jul 29, 2003 1:48 pm
Location: Vancouver, Canada
Contact:

Post by klewlis » Sat Apr 21, 2007 7:27 pm

Paul wrote:Try this in Firefox (I am using 2.0.0.2):

a. Tools -> Options
b. in the resulting dialog, click the 'advanced' button in the middle fieldset entitled 'fonts and colors'
c. ensure that the checkbox labelled 'allow pages to choose their own fonts, instead of my selections above' is checked
d. OK-button your way out of the dialogs

This approach should allow the aforementioned CSS settings (with Arial Unicode MS first) to govern.

Let me know if this doesn't help.

Cordially,

Paul

P.S. - when you say "it doesn't seem to be working for me," what are the phenomena; what do you see?
that box is already checked...

i see tiny, courier font. really hard to read.

Arvid
Textkit Member
Posts: 163
Joined: Thu Apr 05, 2007 8:06 am
Location: Seattle WA

Post by Arvid » Sat Apr 21, 2007 8:36 pm

Chris Weimer wrote:Do you not have Arial Unicode MS installed? It's a nifty little font and I recommend it.
As a Mac user, I find that if I don't use Lucida Grande, Polytonic Greek will not display properly. I've tried all the (dozens of) other fonts that came with OS X, and using any other one, I always get the dreaded boxes. Which is too bad, because Lucida Grande is a sans-serif font I'm not crazy about in Roman.
phpbb

User avatar
Paul
Textkit Zealot
Posts: 700
Joined: Sun Jun 15, 2003 4:47 pm
Location: New York
Contact:

Post by Paul » Sat Apr 21, 2007 8:45 pm

Hi,

What release of Firefox? Use Help -> About Mozilla Firefox.

Thanks.

-pb

User avatar
klewlis
Global Moderator
Posts: 1605
Joined: Tue Jul 29, 2003 1:48 pm
Location: Vancouver, Canada
Contact:

Post by klewlis » Sat Apr 21, 2007 10:18 pm

2.0.0.3

User avatar
Paul
Textkit Zealot
Posts: 700
Joined: Sun Jun 15, 2003 4:47 pm
Location: New York
Contact:

Post by Paul » Sun Apr 22, 2007 1:49 pm

Klewlis,

Can we try another approach? Let's prevent web pages from specifying their own fonts and, instead, try to force a font of our choice. Thus, in 2.0.0.3:

1. Tools -> Options -> Content
2. Click Advanced under Fonts & Colors
3. UNcheck the box labelled "Allow pages to choose their own fonts, instead of my selections above."
4. In the topmost fieldset labelled "Fonts for" against the select list labelled "Proportional" choose "Sans Serif"
5. In the same fieldset against the select list labelled "Sans-serif" choose, say, Arial Unicode MS, or another Greek-capable font.
6. If need be, adjust "Minimum font size" as well
7. OK your way out of the dialogs.

Let me know if this helps.

Cordially,

Paul

User avatar
klewlis
Global Moderator
Posts: 1605
Joined: Tue Jul 29, 2003 1:48 pm
Location: Vancouver, Canada
Contact:

Post by klewlis » Sun Apr 22, 2007 6:55 pm

yeah I set it all to verdana, so now it's better. :)

Post Reply