Textkit Logo

Spionic for Mac-newbie question

Here's where you can discuss all things Ancient Greek. Use this board to ask questions about grammar, discuss learning strategies, get translation help and more!

Spionic for Mac-newbie question

Postby oistos » Sun Mar 20, 2005 5:40 am

Hello,

I went to the suggested site and downloaded Spionic for Mac. However, when I read peoples posts in the forums I still see only the code, not the Greek font. How is it supposed to work, and perhaps I need a different download for OSX?

I haven't posted any questions in the Pharr forum yet because I want them to look right. :oops:

Thanks for your help.
phpbb
oistos
Textkit Neophyte
 
Posts: 40
Joined: Wed Feb 16, 2005 2:16 am
Location: Columbus, Ohio

Postby Adelheid » Sun Mar 20, 2005 2:43 pm

I suppose you placed the font in the appropriate directory?

I put the font in Library/Fonts (system wide), this could also be ~/Library/Fonts (your own user only).

As far as I can remember, there was no other configuration necessary.

Which font did you download? I use SPIonic of Scholars Press.


Regards,
Adelheid
User avatar
Adelheid
Textkit Enthusiast
 
Posts: 422
Joined: Mon Mar 29, 2004 8:58 pm
Location: Mijdrecht

Postby oistos » Sun Mar 20, 2005 8:00 pm

I got it from the link on this forum. When I downloaded it, and unzipped it, it opened a blank panel saying "not installed" and had an install button. I pushed that, and it created an entry in the Font Book, but this entry is blank. You can see all the other fonts when you click on them, but this one is blank, which is why I wondered if I needed something different for OS X?
phpbb
oistos
Textkit Neophyte
 
Posts: 40
Joined: Wed Feb 16, 2005 2:16 am
Location: Columbus, Ohio

Postby oistos » Sun Mar 20, 2005 8:04 pm

I just checked Library/fonts like you suggested. SPIonic is listed, but shows no actual font when you open it.
phpbb
oistos
Textkit Neophyte
 
Posts: 40
Joined: Wed Feb 16, 2005 2:16 am
Location: Columbus, Ohio

Postby oistos » Sun Mar 20, 2005 8:19 pm

I just figured out the problem. I can't see it when I use Safari as my browser. I can see the Greek font when I use Explorer as my browser. This is somewhat aggravating because I like Safari better, and MS is not going to be updating Explorer for Mac. :evil:
phpbb
oistos
Textkit Neophyte
 
Posts: 40
Joined: Wed Feb 16, 2005 2:16 am
Location: Columbus, Ohio

Postby Adelheid » Sun Mar 20, 2005 8:21 pm

I checked: the monachos site (the second link mentioned in the thread) has the font version (1999) that I use.

If you only tried the first link, then try the second one too.

Oh, I just saw your post about Safari: I have this working under Safari, so it IS possible.

Regards,
Adelheid
User avatar
Adelheid
Textkit Enthusiast
 
Posts: 422
Joined: Mon Mar 29, 2004 8:58 pm
Location: Mijdrecht

Postby oistos » Thu Apr 07, 2005 3:10 am

Testing

[face=spionic])/Oistoj[/face]

Typed with Safari.
phpbb
oistos
Textkit Neophyte
 
Posts: 40
Joined: Wed Feb 16, 2005 2:16 am
Location: Columbus, Ohio

Postby oistos » Thu Apr 07, 2005 3:18 am

Well, as you can see, I typed that last message with safari, but I still can't read the Greek font in Safari.
I am typing this message in Explorer, where I can see what I wrote in Spionic in the actual Greek Font.
I downloaded the font again from the monachos site as Adelheid suggested, but the results seem to be the same. Does anyone have any advice?

How about any Ancient Greek swear words?
phpbb
oistos
Textkit Neophyte
 
Posts: 40
Joined: Wed Feb 16, 2005 2:16 am
Location: Columbus, Ohio

Postby Adelheid » Thu Apr 07, 2005 4:48 am

oistos wrote:Well, as you can see, I typed that last message with safari, but I still can't read the Greek font in Safari.
I am typing this message in Explorer, where I can see what I wrote in Spionic in the actual Greek Font.


Just read your message with Safari, no problems. I will test the whole procedure on my other Mac (where nothing spionic-related has been installed yet), but I will probably not be able to do it today. But I will check it out, when I got it working, you can get it working too :D

Can you say which osx version (I have 10.3.8 ) and Safari version (I have 1.2.4) you are running? My text encoding right now is Western (ISO Latin 1).

Regards,
Adelheid
User avatar
Adelheid
Textkit Enthusiast
 
Posts: 422
Joined: Mon Mar 29, 2004 8:58 pm
Location: Mijdrecht

Postby oistos » Fri Apr 08, 2005 2:29 am

Hello Adelheid,

My OS is 10.3.8 like yours and Safari is the same too. I was just wondering if it makes a difference which is your default browser? I changed my default to Explorer a while back to be able to watch some clips on Windows Media Player. Explorer is still my default browser even though I almost always use Safari.

I will try switching it back and let you know.

Thanks again for your help.

Jeff/Oistos
phpbb
oistos
Textkit Neophyte
 
Posts: 40
Joined: Wed Feb 16, 2005 2:16 am
Location: Columbus, Ohio

Postby Adelheid » Fri Apr 08, 2005 4:29 pm

Hi Jeff,

Here's what I did:

I fired up my eMac, checked for SPIonic font, and verified it wasn't available yet on that system.
I started Safari, looked at a textkit thread with spionic: I saw betacode, no Greek characters.
I then downloaded the SPIonic font from the Monachos site, unstuffed the downloaded sit file and placed the font on my desktop.
I double clicked the font, Fontbook opened, and I clicked on Install.
The font was installed to my Library/Fonts folder (User, not the System Library folder, but it shouldn't make a difference).
I quit Safari and started it again, to take a look at the same thread as before: now I could see Greek characters.

Can you describe, step by step, what you did to install the font? It must be something really tiny that we are overlooking.

Otherwise I will help you find those Ancient Greek swear words :evil:

Regards,
Adelheid
User avatar
Adelheid
Textkit Enthusiast
 
Posts: 422
Joined: Mon Mar 29, 2004 8:58 pm
Location: Mijdrecht

Postby annis » Fri Apr 08, 2005 9:45 pm

Adelheid wrote:I double clicked the font, Fontbook opened, and I clicked on Install.


When you do this you are supposed to get a preview of the font in part of the Fontbook window. I noticed that if I didn't get the preview then there was no point in installing the font.

Unfortunately, I don't recall what I did - or where exactly I found the font file - so that I got it to work.

I do know I had to delete and re-install SPIonic a few times before I got it working.
William S. Annis — http://www.aoidoi.org/http://www.scholiastae.org/
τίς πατέρ' αἰνήσει εἰ μὴ κακοδαίμονες υἱοί;
annis
Textkit Zealot
 
Posts: 3397
Joined: Fri Jan 03, 2003 4:55 pm
Location: Madison, WI, USA

Postby oistos » Sat Apr 09, 2005 3:04 am

Adelheid and Annis,

Here is what I did: I downloaded the the file from Monachos to my desktop. I unstuffed it. I clicked on the file and a small preview box opened. As Annis has said, it only actually shoed the characters once. The other times it was blank. I have it installed in my Font Book, so when I open Font Book and choose SPIonic, it actually shows the Greek lettters. The funny thing is that Explorer displayed the Greek text on Textkit even when the file in Font Book was blank.
The Greek letters now show up in Font Book from my most recent download, I've switched my default browser back to Safari, but Safari still doesn't read the code.

Maybe I need to shut down the computer and restart it. :?
phpbb
oistos
Textkit Neophyte
 
Posts: 40
Joined: Wed Feb 16, 2005 2:16 am
Location: Columbus, Ohio

Postby Adelheid » Sat Apr 09, 2005 9:00 am

annis wrote:I do know I had to delete and re-install SPIonic a few times before I got it working.


That is so strange. I had it working on both my systems the first time I tried. On my laptop I didn't even use Fontbook, I just copied the font manually to the Library/Font folder myself.
I even tried the SPIonic font that showed a blank in Fontbook, and replaced it again later with the one from the Monachos site without any problems.

Clear cache? Refresh page? Just guessing now :(

Regards,
Adelheid
User avatar
Adelheid
Textkit Enthusiast
 
Posts: 422
Joined: Mon Mar 29, 2004 8:58 pm
Location: Mijdrecht

Postby Adelheid » Mon May 30, 2005 10:30 am

Hi Oistos,

I installed the new OSX Tiger on my laptop the other day: it was a clean install, so every trace of anything SPIonic-related was erased.

After the installation, I installed the SPIonic font (double-clicking it and all), fired up Safari and could read all the Greek here on Textkit.

So it should really be that simple.

Did you get it to work in the meantime? Just curious.

Regards,
Adelheid
User avatar
Adelheid
Textkit Enthusiast
 
Posts: 422
Joined: Mon Mar 29, 2004 8:58 pm
Location: Mijdrecht

Postby oistos » Tue Jun 07, 2005 3:56 am

Hello Adelheid,

Yes, SPIonic finally works. I didn't do anything. I really had given up. I really began to dispare when IE began to quit on me. Lo and behold about 2 weeks ago SPIonic just started working in Safari. I guess I'll never know what went wrong.

Thanks for your help and interest in my "plight".

Jeff.
phpbb
oistos
Textkit Neophyte
 
Posts: 40
Joined: Wed Feb 16, 2005 2:16 am
Location: Columbus, Ohio


Return to Learning Greek

Who is online

Users browsing this forum: No registered users and 36 guests